Selected Dataobjects are removed

Developer
Apr 19, 2012 at 8:32 AM

I like the initive of improving the use of SqlMetal, and the program almost works, except:

A few issues have occurred when I ran from source:

  1. The location of Sqlmetal is configurable, but the program does not check existence before running, this causes recurring exceptions in _sqlMetalWorker_RunWorkerCompleted.
    Configuring the location to my SqlMetal location (C:\Program Files (x86)\Microsoft SDKs\Windows\v7.0A\Bin) remedied the problem 
  2. A similar issue, but remedied easier: the project SqlMetalInclude is not referenced by SqlMetalIncludeGUI, and therefore not automatically copied to the oputput directory, causing the same kind of issue. Refering the project solved the issue.
  3. Even though I selected some objects, the output window stated It removed all of them, and when I saved the code file, It only contained the Datacontext. The execution. It look like a casing issue:

Executing 'SqlMetalInclude.exe /dbml:"FullDbMap.dbml" /output:"Demarrage_ProcessedDbMap.dbml" /verbose /include:dbo.tbl_Users=Tbl_Users/Tbl_User,dbo.tbl_Zones=Tbl_Zones/Tbl_Zone'

SqlMetalInclude

Table dbo.tbl_Users removed.
Table dbo.tbl_Zones removed.

SqlMetalInclude execution completed with no errors
(Do you care if I submit some of my code cleanup?)

Developer
Apr 19, 2012 at 8:47 AM

Furthermore my compliment on enabling a mapping between database-objects and business objects, a lot of my tables start with tbl_, but I do not wnat them in my entity classes.